Some meetings are processing slowly or failing due to a third-party provider issue. We're working to resolve it.

Incident Report for CoRecruit App and Service Status

Resolved

This incident has been resolved.
Posted Sep 01, 2026 - 15:57 EDT

Identified

We're aware that some calls are taking longer than usual to process, and in some cases failing to process at all.

This is being caused by an issue with a third-party provider, Twilio, who we rely on for our calling infrastructure. Their team has identified the issue and is actively working on it, and we're in direct contact with them to help resolve this as quickly as possible.

There is no workaround at this time. Calls affected by this issue should process automatically once the underlying issue is resolved.

We'll post an update here as soon as the issue is resolved. If you're affected and need immediate help, please contact our support team.
Posted Sep 01, 2026 - 13:24 EDT
This incident affected: Meeting Processing.