We are continuing to monitor for any further issues.
Posted Mar 24, 2026 - 15:43 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2026 - 15:43 EDT
Investigating
Some users may be experiencing slow loading times in the app dashboard. We believe this is related to scheduled maintenance currently being performed by our infrastructure provider, Cloudflare, which may be causing a slight increase in latency for some regions. We are monitoring the situation closely. If you experience issues, please try refreshing your browser.