Degraded Performance – Dashboard & VOIP Calls Affected

Incident Report for CoRecruit App and Service Status

Monitoring

We can confirm that the slow loading times some users are experiencing on the CoRecruit web and mobile apps are related to ongoing scheduled maintenance by Cloudflare, a major internet infrastructure provider.

Upcoming Maintenance Windows:
The following regions may experience intermittent slowdowns or brief interruptions when accessing CoRecruit:
πŸ‡ΈπŸ‡¬ SIN – Singapore: Mar 25
πŸ‡ΏπŸ‡¦ CPT – Cape Town: Mar 25–26
πŸ‡«πŸ‡· CDG – Paris: Mar 25–26
πŸ‡¨πŸ‡Ώ PRG – Prague: Mar 26
πŸ‡¨πŸ‡­ ZRH – Zurich: Mar 26–27
πŸ‡¬πŸ‡§ LHR – London: Mar 26–27
πŸ‡ΊπŸ‡Έ CMH – Columbus: Mar 27
πŸ‡ΊπŸ‡Έ LAX – Los Angeles: Mar 27 & 30
πŸ‡§πŸ‡ͺ BRU – Brussels: Mar 30–31

If you experience slow loading times, please try refreshing your browser or app and checking back after a few minutes. Disruptions are expected to be temporary.

We will update this post as maintenance windows complete or if the situation changes.
Posted Mar 25, 2026 - 17:27 EDT

Investigating

We are currently monitoring two separate incidents with our infrastructure providers that may be impacting your experience.

Dashboard Loading – Cloudflare Maintenance
Some users may experience slow dashboard loading times due to ongoing maintenance being performed by Cloudflare. This does not affect all regions, but users in impacted areas may notice slower than usual load times. We are actively monitoring the situation.

VOIP & Caller ID – Twilio Degraded Performance
We are also seeing degraded performance from Twilio, our VOIP provider. This may cause intermittent issues with calls using Caller ID or VOIP functionality. Our team is monitoring this closely and will provide updates as they become available.

We will update this post as either situation changes. If you are experiencing issues, please don't hesitate to reach out to our support team.
Posted Mar 25, 2026 - 11:56 EDT
This incident affects: CoRecruit Application.