Meeting Bots Temporarily Unavailable – Use Desktop App to Record

Incident Report for CoRecruit App and Service Status

Resolved

This incident has been resolved.
Posted Mar 24, 2026 - 15:42 EDT

Update

The outage affecting our meeting bots and transcription service has been resolved. Our service provider, Recall.ai, has confirmed the incident has been mitigated and all services are operating normally.

The following have been restored:
- Meeting bots are joining scheduled and ad-hoc calls as expected
- Transcription processing is back to normal
- Calendar connections and syncing are functioning as expected

We sincerely apologize for any disruption this caused. If you have any concerns about meetings that were not captured during the outage window, please reach out to our support team.

Resolved: March 24, 2026 at 2:45 PM UTC
Posted Mar 24, 2026 - 15:42 EDT

Update

We are continuing to investigate this and are waiting for an update from Recall.ai on the status of their outage. We will keep posting updates here as soon as we have new information.

Apologies for this inconvenience.
Posted Mar 24, 2026 - 12:04 EDT

Investigating

We are currently experiencing an outage with Recall.ai, the service provider we use to power our meeting bots. This is preventing bots from joining calls at this time. Recall.ai is actively investigating and has indicated a further update by 9:00 AM PST.

Workaround: If you need to record a meeting right now, please use the CoRecruit desktop app to record locally instead.

We will update this post as we receive more information.
Posted Mar 24, 2026 - 11:56 EDT
This incident affected: CoRecruit Application.